This project is read-only.
3
Vote

uTube version 1.1 : Installation error in umbraco 4.7.0

description

When installing, received the error "The given key was not present in the dictionary."
 
Setup is umbraco 4.7.0, no other packages installed, no modifications made to source, no runways installed, only a few doctypes and templates set up manually with nothing special on em.
 
Running Windows 7 Ultimate x64, IIS 7.5, SQL 2008 express, .net 4 etc.
 
Installation seemed to copy in appropriate files, and update the installedPackages.config to include:
 
<package id="1" version="1.1" url="" name="uTube" folder="336a4c27-fcba-40e9-a377-30eedcacc29e" packagepath="" repositoryGuid="" packageGuid="" hasUpdate="False" enableSkins="False" skinRepoGuid="00000000-0000-0000-0000-000000000000">
<license url="http://www.opensource.org/licenses/mit-license.php">MIT license</license>
<author url="http://utube.codeplex.com/">uTube Team</author>
<readme><![CDATA[This package installs the following:
 
[Macro] uTube Chromeless Player
 
[Macro] uTube Classic Player
 
[DataType] uTube Video Picker
 
[DataType] uTube Video Uploader
 
[Media DocumentType] YouTube Video (Upload)
 
Team uTube are:
 
Warren Buckley - @warrenbuckley
 
Lee Kelleher - @leekelleher
 
Morten Christensen - @sitereactor
 
Chriztian Steinmeier - @greystate]]></readme>
<actions>
</actions>
<datatypes>
</datatypes>
<content nodeId="" loadChildNodes="False">
</content>
<templates>
</templates>
<stylesheets>
</stylesheets>
<documenttypes>
</documenttypes>
<macros>
</macros>
<files>
  <file>/bin/Google.GData.Client.dll</file>
  <file>/bin/Google.GData.Extensions.dll</file>
  <file>/bin/Google.GData.YouTube.dll</file>
  <file>/bin/uTube.Core.dll</file>
  <file>/css/uTube/player-buttons.png</file>
  <file>/css/uTube/sound.png</file>
  <file>/scripts/uTube/chromeless.player.js</file>
  <file>/usercontrols/uTube/post-install.ascx</file>
  <file>/xslt/uTube/chromeless.player.media.xslt</file>
  <file>/xslt/uTube/chromeless.player.xslt</file>
</files>
<languages>
</languages>
<dictionaryitems>
</dictionaryitems>
<loadcontrol>
</loadcontrol>
</package>
 
 
However, only seemed to add the one datatype: uTube Single Video Picker - the other one, uTube Video Uploader, was not added
 
Viewing the Single Video datatype, it is configured to have a render control of Checkboxlist - so perhaps this is where the failure occurred. The three uTube render control options of Single Video, Video Picker and Video Uploader are available to choose in the dropdown on the edit datatype screen.

comments

Hellberg wrote Aug 16, 2011 at 8:51 AM

I'm also having this problem when installing the package in Umbraco 4.7.0. However, I don't have the three render controls available in the dropdown list on the edit datatype screen either.

wrote Feb 22, 2013 at 12:48 AM